Version for .NET 4.0

Topics: Platform
Feb 13, 2011 at 9:50 PM

Hi,

I just downloaded the source to a  64-bit Windows Server environment. I want to develop for .net 4.0. Trying to compile gave problems when I changed the references fro, 3.5 to 4.0,

I'll try to solve them myself unless you have got a 4.0 version ready.

If so, please post it.

Best regards,

Jan

Coordinator
Feb 13, 2011 at 11:26 PM

We're still working in VS2008 as we don't get VS2010 yet. We will upgrade to .NET 4.0 in the second half of this year, I think. When you resolve them by yourselves, please can you write down the solution and share with us here? Thanks.

Feb 14, 2011 at 9:40 PM

OK.

I opened the solution in VS2010. The conversion was done without errors. I changed all 3.5 references to 4.0. Had to adjust the configPages entry in the web.config.  Changed the properties of each project to deploy for 4.0. Added the database (RapidWebDev), run the scripts. Changed the connectionstring in web.config.

I was able to compile the solution.

When I start the web app in debug mode, an error occurs in installerManager.cs. There is no entry in the aspnetApplications table. Should there be one? How does it get filled?

When I try to use the MS stuff that allows one to add users and groups to a webite, there is an error in some SPRING module.

Folllowing the quick setup script from your website gives the same problems. Trying to run the unit tests gives an error on the signature of the dll.

Feb 17, 2011 at 3:34 AM

If you try on VS2010.

Dialog will show "Convert from 3.5 to 4.0" first time.

You should select "Don't Convert".

The Error will not appear.

 

sorry in English Syntex.

 

Feb 17, 2011 at 4:51 PM

But I need to develop for 4.0!

Feb 20, 2011 at 5:59 PM

I tried the application on VS 2008 (ASP.NET 3.5) with SQLServer 2005.

Then I am able to open the logon screen.

When I am loged on and try to do something, a pop up screen occurs telling there is an error and that that error is being logged.

Where is it logged?

 

When I try to change the password, an error is given on JQuery (?).

Coordinator
Feb 21, 2011 at 4:11 AM

The folder names log4net which includes all logs. It's under the web application root folder. 

Feb 21, 2011 at 6:30 PM

Thanks.

 

De default culture (nl) appears not te be accepted.

I'll try to research this somewhere later this week.